Your host needs to use PHP 5.3.1 or higher to run this version of Joomla!

Alot of members have problem when Joomla 3 installation “Your host needs to use PHP 5.3.1 or higher to run this version of Joomla!”

What solutions?


1. Contact to your hostting Supporter to ask about joomla and PHP5.3.1 or higher version, Or use other hosting Provider to support PHP5.3.1 or higher

I recoomended Webhostings for Bloggers and Designers because I am freelancer, working with thousand clients in the worlds. Most of them will use those hosts.

vinaora vinaora

 

2. you can add some code to your .htacess and php.ini files and then check it again

Rename your htaccess.txt file to .htaccess.
Open the file and add this code.
Change “myusername” and “yourJ3folder” to match the folder names that you are using.

<IfModule mod_suphp.c>
suPHP_ConfigPath /home/myusername/public_html/yourJ3folder
<Files php.ini>
order allow,deny
deny from all
</Files>
</IfModule>

Create a file called php.ini.
Add the code below:

magic_quotes_gpc = Off
extension=pdo.so
extension=pdo_mysql.so

3. Changing the PHP version is done through cPanel

Log into cPanel
Find the icon PHP Configurationand click on it.

Older servers will not display this option, however you can request to be moved to a newer server that has this ability. You can submit an email to support@inmotionhosting.com requesting to be moved. Please verify your account in the email by providing your current AMP password or the last four digits of the credit card on file.
php_1
Select the version of PHP you want to use from the dropdown.php_5-4
Click the Update button to save your php configuration.

Be Sociable, Share!

Leave a comment