SP Upgrade – Upgrade Joomla from 1.5 to 3.0 (or 2.5, 1.7, 1.6)

Upgrade Joomla from 1.5 to 3.0 (or 2.5, 1.7, 1.6)

Note: Anything below is mentioned for version 3.0 goes the same for 2.5 and 1.7 and 1.6. The component is able to migrate to all 3.0 or 2.5 or 1.6 or 1.7.

Migrate your old sites from Joomla 1.5 to 3.x with one-click and keep safe your Google Rank. All 3.x, 2.5, 1.7 and 1.6 releases are supported.

Now migration to Joomla v3.x is easy and safe. The component read directly from your old 1.5 db and save to the new 3.0 db using core Joomla functions. By utilizing the Joomla core functions the loaded components are build in the database, as if you create them manually, but keeps the same ids. That means 100% compatibility, stability and utilization of the new Joomla features (expanded access control system and nested categories).

The component is able to load from your old 1.5 database to the new the following:

* Users
* Articles (along with their Sections and Categories)
* Contacts
* Web Links
* News Feeds
* Banners
* Images
* Menus
* Modules
* Majority of Templates (Only core templates files are migrated. Some templates comes with additional extensions e.g modules. Those are not migrated.)

Excluding Sections the same ids are loaded to the new database. That means you keep your old links untouched therefore you do not harm your Google Ranking.

 

The component is able to load from your old 1.5 database to the new the following:

  • Users
  • Articles (along with their Sections and Categories)
  • Contacts
  • Web Links
  • News Feeds
  • Banners
  • Images
  • Menus
  • Modules
  • Some Templates (Only core templates files are migrated. Some templates comes with additional extensions e.g modules. Those are not migrated.)

This component does not migrate any non-core extensions.

Unique Features

What is different from other similar tools?

  • Same id’s– Why is this so important?
    1. Google ranking is not affected
    2. No broken internal links (e.g. within your articles)
    3. No broken external links. Those are links from other domains to your site
  • Safe – The component do not mess with your live J15 site. There is no chance to harm your live site.
  • Continuity – If for any reason the migration is interrupted (e.g. due to your server maintenance) you can continue from the point it stopped.
  • Support – No matter what, we assist you all the way to migrate successfully.

All Features

  • It does the job – Yes it migrates Joomla 1.5 to 3.x with no problems. See below the requirements.
  • Simple – The process is… simple. No technical knowledge is required.
  • Automation – Migration process is fully automated.
  • Compatibility – Loading process simulates human manual creation resulting all content to be fully compatible and ready to utilize the new Joomla features.
  • Same id’s – The id’s of all items remains the same, except from sections
  • Monitoring – Monitor real-time the process of migration (suitable for big sites) and review the stored log results.
  • Scalability – No problem either you migrate 10 or 100.000.000 items. It just takes longer!
  • Safe – Read only from your live 1.5. No updates at all.
  • Security – You are able to migrate with a read-only database user of 1.5. Useful for outsourcing the migration process.
  • Remotely – You can migrate from a remote server where your live 1.5 site is located, to another remote server (e.g your development environment, or local PC) where the new 3.x installation is located.
  • Continuity – Repeat process as many times as wish. It keeps track what is already migrated.
  • Menus – Ability to transfer all menu items, and not only of the core components.
  • Language – All languages are supported.
  • Support – Free support and release updates for six months.

Installation

Steps to install the component are those of a normal Joomla extension installation. The component is installed on your Joomla version 3.x site.

  1. Download the component
  2. Upload and install from Joomla 3.x back-end extension manager.
  3. After the installation you are automatically redirected to the component.
  4. That’s it!!!

Requirements

  • PHP 5.x
  • Joomla 3.x.xx *
  • Joomla 2.5.xx *
  • Joomla 1.7.xx *
  • Joomla 1.5.xx **

Migration of images and templates is not working on Windows environment.

* The component is compatible with all the available versions 3.x, or 2.5, or 1.7 or 1.6 and above.

** The component is tested thoroughly with Joomla 1.5.22 and 1.5.23. It does migrate older versions but if you are running Joomla 1.5.11 or lower you will need some manual corrections on the menus.

How to upgrade

The upgrade process is very simple:

  1. Install Joomla v3.x. Do not to install sample data.
  2. Fill the version 1.5 database information. If you are not sure what to put here you should ask your provider.
  3. Press button “Upgrade”
  4. Fix modules positions to the new template
  5. Test. Before you move to production test your new v3.x site.

No need to do anything on your v1.5 database, since the component only read and do not update.

Be Sociable, Share!

Leave a comment